[Solved] 7-Zip - Version not detected


  • Community Moderator

    7-Zip (bundled with Star Citizen) is found on my system but the installed version is not detected (the text ? is shown)

    Here is the version information extracted from 7z.exe:

    File name and path: E:\StarCitizen\RSI Launcher\resources\app.asar.unpacked\node_modules\7zip\7zip-lite\7z.exe
    Product name:       7-Zip
    Internal name:      7z
    Original filename:  7z.exe
    
    File description:   7-Zip Console
    Company:            Igor Pavlov
    Legal copyright:    Copyright (c) 1999-2015 Igor Pavlov
    Comments:           
    
    File version:       15.05 beta
    Product version:    15.05 beta
    Assembly version:   
    

    Star Citizen did not update 7-Zip a longer time, so you should detect that version correctly.
    Ans also flag it as "Beta" version (see Handling of Beta versions).


  • Community Moderator

    Cool, now you show version 15.05 beta
    Issue solved!


  • VulnDetect Team Member

    Can you check again?


Log in to reply